What's new

Sound and performance issues 0.13.15

straylight

New member
Hey folks, I've been looking forward to this update. Unfortunately when I play the game the Music, Ambient and Sound Effects channels seem to be having some sort of interference (like radio interference, fuzzy buzz sounds and stuttering). It happens when there's music, when birds chirp or when followers chat. It gets worse when I move the cursor and seems to go away once I leave the cursor still for a few seconds, but comes back. I've turned those volume sliders down to in different combinations and that eliminates hearing the interference sounds (so I presume it's coming from the game, not my sound card, plus it doesn't happen in any other game).

Moreover, the game runs more sluggishly than in 0.12.19. There's a noticeable, but not significant, delay between pressing buttons and getting results. In Task Manager the game appears as using up 90-95% of my CPU and 70-80% of RAM quite consistently over time, which is something I don't see often even when I play MMOs. I don't know if there is any correlation between the sound issue and the sluggishness issue.

Specs: IntelCore i5 5200U, 8 GB RAM, Nvidia gtx950M with 4GB dedicated RAM, and all SSD. Win 10 Home.
(if the performance issues are due to my old laptop then sorry :p)
 
Last edited:

Rutger

Abbey Games Developer
Developer
Hey straylight,

Sorry that you're running into this! Could you upload your abbeycore.txt log file? That should contain some Wwise logging to see what might be happening :)
 

Blackvision

Well-known member
Kickstarter Backer Community Member for 2 years
I've had a few issues with the previous build along these lines, but I know mine's at least partly my computer wearing itself out. I am surprised that Godhood burns it out as much as something like Total Warhammer does though, even on the lowest settings it's still stuttering sometimes (if very rarely). (Enter the Gungeon, in comparison, does not)
 

straylight

New member
Hey straylight,

Sorry that you're running into this! Could you upload your abbeycore.txt log file? That should contain some Wwise logging to see what might be happening :)
Damn, if only I'd read this before stepping out! I'll upload it today. I hope it's something easily patchable so I can play in peace (or war, or lust, or chastity...)
 

Rutger

Abbey Games Developer
Developer
Also, if you could upload a save file that you are having issues with, we can inspect the state and see if anything especially funky is going on :)
 

straylight

New member
Here's the abbeycore. I notice a lot of Garbage Collection Spikes.

Where are saves located by default? I can't find any saves in steamapps>common>Godhood.
 

Attachments

Rutger

Abbey Games Developer
Developer
Thanks! By default Steam cloud save is enabled: the files should be located in [your steam installation directory]/userdata/[your user id]/917150/
 

Rutger

Abbey Games Developer
Developer
Hm, the log doesn't indicate any serious issues. I would recommend updating your graphics drivers, they're three years old at this point. That might help with the performance a bit :)
 
  • Like
Reactions: Bas

straylight

New member
The drivers were updated today and before that in the past few months (in no case 3 years old - I have no idea why the DriverDate in abbeycore is 2016). The problems persist. And in any case, the sound problems are the most annoying, not the performance issues.
 
Last edited:

Rutger

Abbey Games Developer
Developer
Small update: we've received reports about this from multiple people. It seems to be linked to performance issues mostly: can you confirm that the frame rate isn't very good in your experience? In the meantime, we're trying out making the memory buffer for our audio systems a bit bigger, but we're not sure if that will fix the problem.
 

straylight

New member
I don't get any noticeable framerate problems when the stutters/crackling happens. Is there any way to constantly show the framerate in a corner of the screen so I can check more thoroughly?
 

Blackvision

Well-known member
Kickstarter Backer Community Member for 2 years
There's an option on Steam - Steam, Settings, In-Game, Change the 'In-Game FPS counter' option from 'Off'.
 
Top